Help Wanted - Installing Ubuntu on HP ProBook - BIOS issues

Hello all!

I’m attempting to install the latest Ubuntu LTS version 20.04 on several donated laptops. The hard drives came wiped but previously had Windows installed on them. The laptops are HP ProBook’s.

I’m attempting to setup the donated laptops with Ubuntu and downloaded and burned the Ubuntu install media to a DVD with the hopes that I could quickly and easily have Ubuntu up and running on them. It’s 2022 and these laptops aren’t super ancient so I was hoping it would be a breeze.

After a lengthy “Checking disks” startup process it boots into the Ubuntu Desktop GUI and an Install Wizard window pops up.

I perform the following actions in the Install window:

  1. click the “Install Ubuntu” option.
  2. Select the keyboard layout, click continue
  3. Connect to a wireless network successfully and click continue

It then gets to a “Updates and other software” screen which says

You need atleast 8.6 GB disk space to install Ubuntu.
This computer has only 0.0B.

The Continue button is greyed out with only the Quit and back buttons available.

When I click the “Quit” button the Ubuntu desktop GUI goes away for a few seconds and I see 4 repeated error messages in a console window stating:

ima: Error communicating to the TPM chip

I’ve also been able to get a terminal window open and can see the following relevant entries when executing the dmesg command:

DMI: HP ProBook 650 G1/2101, BIOS L78 Ver. 01.40 07/13/2017

AppArmor: AppArmor sha1 policy hashing enabled
ima: Error communicating to TPM chip
ima: Error communicating to TPM chip
ima: Error communicating to TPM chip
ima: Error communicating to TPM chip
ima: Error communicating to TPM chip
ima: Error communicating to TPM chip
ima: Error communicating to TPM chip
ima: No architecture policies found

I’m assuming the problem is related to this: How to solve “ima: error communicating to tpm chip” messages during boot - Ask Ubuntu
but it is getting very frustrating and time sucking trying to tweak settings in the BIOS that maybe related to TPM and begin the whole process over with low confidence of success.

I’ve tried tweaking several BIOS settings and rebooting but have still been unable to detect the hard drive. Some of these BIOS settings present big warning messages before continuing which increases the fear factor of changing some of the settings.

Any help is appreciated. I’m still holding out some hope that after this hard disk / BIOS setting is corrected that everything will go more smoothly but this is a very early and discouraging setback.

FYI I tried to post this to the BLUG community but it doesn’t look like my user has the ability to create new topics there. If this topic can be moved to the BLUG community so it gets more visibility through people’s emails that would be appreciated. Or if the permissions can be updated so I can post new topics to the BLUG community via the site that would be appreciated as well.

@Bhamcoder I added you to the BLUG group… as noted on the sticky post Welcome to the Bellingham Linux Users Group - #2

1 Like

Well I figured out the issue. The reason why the ubuntu installer was showing 0.0B was because the donated laptops had the hard drives removed. :man_facepalming: Yeah, I should have checked first before assuming an OS / driver issue.

LOL. I was going to post about ACHI vs. ‘host RAID’ issues - but clearly that wouldn’t have helped you :wink: